View Full Version : No fuel pressure.

09-19-2005, 09:12 PM
Hello,I parked my 86 GN about 1 year ago after breaking the crank sensor bracket. Ready to get it back on the road I have replaced the crank sensor and bracket. Got as much of the old gas out of the tank and added 10 gallons to it. Have changed the plugs and getting fire to all 6. Tried to start the car, would not start. Put some gas in the throttle body and it fired right up, but only ran for about 10 sec. or long enough to burn the gas I had put in the throttle body. I did this about 4 times and still would not run. When I turn the switch on never did hear the relay up front come on. Unpluged the hood light pluged into test relay connector. Now I can hear the relay come on when I turn on the switch but the car still will not start. So I put some more gas in the throttle body ran same as before, about 10-15 sec. but this time I did hear the turbo spool, not sure why but the turbo never did spool when I did not have the test relay pluged up. Not sure what is going on here. Fule pump?,fule pump relay?, maybe something else? I am lost. Car ran like a top when I parked it. Should not have let it set so long. Maybe someone has had this problem and can help me out.Thank you in advance for your time.

09-19-2005, 09:49 PM
Uh...if the car is idling, your turbo will definitely not be doing any 'spooling'. It takes a lot of fast exhaust flow to get it to 'spool'. Wait until the car is running and warmed up.

If you have the intake tract open, the MAF will not be reading any signal. I'm surprised if it would run at all. Try disconnecting the MAF sensor electrical connection if you want to see if it will run all opened up like that. It will run, but not optimally.

Otherwise, try putting it back together first.

If you are not getting any pump prime, your pump relay may have failed or you may have a blown fuse.

09-19-2005, 11:41 PM
The turbo did spool because I was giving it gas to try to keep it running. The first 4 times I tried I did not have the test relay wire hooked up to the hood light wire the turbo did not spool then. Anyway the problem I have is with fuel. I am taking the hose off the front of the intake, then pouring a little gas in. I put the hose back on the intake before trying to start the car. It will run but only long enough to burn the gas I have put in the intake. It is not getting any gas from the tank. If the wire that goes to the hood light is plugged into the relay test wire I can hear the relay come on before and after trying to start the car. If I do not have the wire plugged in the relay does not come on at all. Also when I have the hood light wire plugged in the chime (for example the alarm you hear when you open the door) never goes off when trying to start the car. Sorry but alot is going on that is hard for me to explain.

09-20-2005, 02:15 AM

If you have the wire described under power (via the hood light connection), the pump should be on all the time and should be audible. Even if the engine is off. See the diagram. However, there are still two fuses that must be good for the fuel injection and igniton circuits to work. If the pump is not on continuously before you stick a key in it, there is another problem. The fuses may be blown. I don't think the relay needs to be functional in this scenario, but I know when I use this method for fuel change out, my relay gets activated. So yours should be getting kicked as well.

You state that the relay is activated. Can you hear the pump run as well? Is the wire harness at the tank connected?

The chime noise should be ignition circuit related and not fuel circuit related. Perhaps that is a sign of a blown fuse.

And, not that it is relevant here, but I consider a 'spooled' turbo to have been spun up enough to where it is actually generating boost and not just idilly spinning because the engine happens to be running. It doesn't sound as if your engine has been running long enough at one sitting to drop the car in gear and run it up hard against the converter.

09-20-2005, 09:47 AM
Electronics issues aside, if the car has been sitting for a long time then there is a really good chance that the fuel pump is gummed up and isn't pumping the proper pressure and volume, if it's pumping at all.

I would check to see if you are getting the correct fuel pressure and flow at the rail.


09-20-2005, 10:11 PM
Can not hear pump running. Wire harness is connected. Have not checked fuel pump to see if it is gummed up. Checked all fuses in fuse box, all ok. Any fuses at other locations besides fuse box? Not sure what fuses to check other than what is in the fuse box. I do not know how to check pressure or flow at the rail. I would assume the fuel injection and ignition circuits work as it will run as long as I put gas in at intake, after it burns the gas up I put in it dies. I am plugging the hood light wire into a connector that was unplugged just under the altenator. Is this the correct plug for testing the fule pump? Why was it unplugged? It is the only one the hood light wire would fit into that I could find. But it was allready unplugged. Thanks for any help, I need it.

09-20-2005, 10:27 PM
I'm not experienced with GNs specifically, so understand that this advice is based on my experience with various other cars...

If you can hear the fuel pump running then you know that the fuel pump is getting power. Therefore you don't need to worry about fuel pump fuses. You know they're good.

Here are some things I would check:

1. Make sure the injectors are getting power. That means checking the fuse(s) related to fuel injection and the ECM. You can also get test devices called "noid lights" that light up when an injector fires. They are pretty cheap and you should be able to buy a set or maybe borrow a set from an auto parts store. That will allow you to verify that your injectors are getting power.

2. If the injectors are getting power, they could be stuck closed...but I find that unlikely. Maybe one of them would be stuck, but then the engine would still run, just rough. Again, unlikely.

3. The fuel pump might be putting out low pressure or volume--in other words, it could be running, but not well enough. You can hook up a pressure gage to the fuel line at the rail and check to see if it is giving you the correct pressure. There is also a "volume/flow rate" test. To do this, you disconnect the gas line at the rail and point the end into a measuring container. Then turn the ignition to "on". The fuel pump should deliver a minimum amount of gas in the few seconds that it runs. I don't know the specific pressure/volume numbers to look for, but maybe someone else can chime in about that....or get a Chilton's or Hayne's manual. They usually describe how to do this. If the volume and/or pressure isn't right, then you may need to replace the fuel pump, fuel pump wiring, regulator, or filter.

09-21-2005, 12:54 AM
Can not hear pump running. Wire harness is connected. Have not checked fuel pump to see if it is gummed up. Checked all fuses in fuse box, all ok. Any fuses at other locations besides fuse box?

There are two connectors. The green one is a tap for a tach. DO NOT USE. There should be a black one that is the fuel pump test lead. That is the one to use.

When you hit it with power, you should hear the relay click (it is under the hood) and the pump run (it is in the rear of the car, inside the tank). Note that your fuse for the hood light must not be blown, either.

You have already said the pump is not running. That may indicate you are hooking it up to the wrong circuit, the relay is bad, you have no power on the hood light circuit (i.e. blown fuse), or there is a fault in the wiring.

Having a voltmeter would not hurt right now.

Are you on the right connector?

Do you have power for the hood light? Is the fuse good? (Might be the signal light or interior light circuit)

Do you hear the relay click when it is connected?

09-21-2005, 06:44 PM
Using the black connector plugged into the hood lamp wire I do hear the relay come on before and after trying to start the engine. When trying to start door chime goes off continously, also boost and rpm gauges are maxed out. It does this with the test wire and hood lamp wire plugged in, when not plugged in it does not. The fuel gauge is also past full mark with only about 10 gallons of gas in the tank.. No sound from fuel pump or tank. Still troubleshooting. Thank you all for the help.

09-22-2005, 02:10 AM
If your gauge is off the scale, your pump is not connected. Check the connector between the rear bumper and tank that leads to the pump. It is probably open. Or that circuit is.

Is the tach maxed out ONLY with the pump connector hooked up? (Hard to understand from description) If so, you may actually be on the tach connector. Can you post a pic of the connector/wire? It should have a black connector and grey wire, I belive. Tach should be green with a white wire.

09-24-2005, 02:37 PM
Tach is maxed out with or without pump connector hooked up. I am sure I am plugged into the correct wire, it is the black connector just behind the altenator. The fuel pump relay only comes on when I have the test connector plugged into the hood lamp wire. I checked and unplugged then plugged back up the connector behind the fuel tank. Still no fuel pump running.

09-24-2005, 04:48 PM
Perhaps the pump is simply kaput.

Do you have a voltmeter? It would be nice to know if power was getting to that connector down by the tank before you tear the tank out.

As to all your other electrical maladies...not even sure where to start. :nope: Sounds like a real mess. Can you find the tach connector and is anything plugged into it?

09-24-2005, 05:23 PM
Is it possible that the sound I am hearing is the antenna motor coming on rather than the relay? I had my wife try starting the car while I listen. The sounds like the antenna motor coming on. Where is the relay? Also I was just double checking all the fuses an when I pulled the 30 amp fuse it looked ok, put it back in and when I did the fan came on for about 3 sec. Turned the switch back on and now the relay is not coming on or the antenna motor. The sound that I was hearing antenna or relay it has not came back on after I pulled the 30 amp fuse. I am so lost. Before the crank sensor broke, the reason I parked the car about a year ago, the car ran fine. Guess sitting kills. Nothing is plugged into the tach connector. It is the one next to the relay test connector, correct? They were both unplugged behind the altenator.

09-24-2005, 05:27 PM
Does your car have a "hot wire kit"? If so check that 30 amp fuse. Mine was blown! I was looking everywhere but there til I noticed it. :shock:

09-24-2005, 05:34 PM
The 30 amp fuse in the fuse panel? That is the one I took out and checked. When I put it back in the fan came on for about 3 sec. Now I can not hear anything from the front passenger side of the car before or after trying to start the car. whit or without the test connector plugged up. Before I pulled the 30 amp fuse and it did the fan thing I coud hear something come on up there. Not sure though if it was the antenna motor or the relay. Sounded like it was coming from the antenna moror area but it is not doing anything now.

09-24-2005, 07:10 PM
So...is it blown now?

Antenna only comes up if the radio is on.


You may need some help at this point. If you don't have a scanner or voltmeter, going further is going to be very tough.

09-24-2005, 09:21 PM
The 30 amp fuse in the fuse panel?

No, the one under the hood. A wire should go from the back of your alternator to a 30 amp fuse then to a relay somewhere under the hood. That is "IF" you have a "hot wire kit" installed in your car. I didn't know my car had one because I bought it only last year. Good thing I didn't purchase another hot wire kit. :yummy: